Share
Explore BrainMass

Java Code Layout, Use of Variable Names, General Readability

I need assistance in commenting on the enclosed code, consider things like code layout, use of variable names, general readability and understandability.

The enclosed program implements a class called ShortAddress that has the following attributes: firstName, secondName, and phoneNumber. Also, implement a class called FullAddress that inherits the above attributes while adding the attributes (int) houseNumber (simply 1, 2, ... etc. - i.e. no 1a or 3b's allowed), street1Name, street2Name and cityName. Use the keyword super in the constructor. The application class should allow the user to input address details and then give the user the choice of viewing the short address details or the long address details. This means the code should have a minimum of 3 classes for the application. Furthermore, use exception handling to make the program robust.

Attachments

Solution Preview

In general it is a good software programming practice to follow variable naming conventions. For example, include abbreviated form of variable type as prefix.

My comments on the following classes:

ShortAddress.java
Rather than declaring and assigning default values to public variables, they should be ...

Solution Summary

In general it is a good software programming practice to follow variable naming conventions. For example, include abbreviated form of variable type as prefix.

$2.19